Configurar port mirroring en Cisco IOS

( redes / cisco / ios )

Port mirroring es una función que tienen los switches para copiar todo el tráfico de un interface específico a otro interface para replicar TODO el tráfico y así poder capturarlo con alguna herramienta tipo tcpdump o whireshark.

  1. Configuramos las interfaces de forma idéntica (no es obligatorio que las interfaces sean del mismo tipo pero es aconsejable):
    interface GigabitEthernet0/1
     switchport
     switchport access vlan 10
     switchport mode access
     spanning-tree portfast
    
    interface GigabitEthernet0/2
     switchport
     switchport access vlan 10
     switchport mode access
     spanning-tree portfast
  2. configuramos mirroring en las interfaces:
    monitor session 1 source interface GigabitEthernet 0/1
    monitor session 1 destination interface GigabitEthernet 0/2
  3. comprobamos el estado del mirroring:
    #show monitor detail
    
    Session 1
    ---------
    Type              : Local Session
    Source Ports      :
        RX Only       : None
        TX Only       : None
        Both          : Gi0/1
        Source VLANs      :
        RX Only       : None
        TX Only       : None
        Both          : None
    Source RSPAN VLAN : None
    Destination Ports : Gi0/2
        Encapsulation : Native
              Ingress : Disabled
    Filter VLANs      : None
    Dest RSPAN VLAN   : None

Retro

Lugares

Redes

Sistemas

Varios